support Windows Phone 8.1 devolop

Topics: Windows Phone 8
Sep 8, 2014 at 4:23 AM
I have can update project to suport devolop windowphone 8.1 sdk in project?

Please help me! Thanks!
Coordinator
Sep 8, 2014 at 6:14 PM
Right click on project -> Options -> Application -> Platform/OS : Windows 8.1

That doesn't work?
Sep 9, 2014 at 8:45 AM
Right click on project -> Options -> Application -> Platform/OS : Windowsphone 8.1 . It is run ok,But sdk develop is windowphone8 not windowphone 8.1

Right click on project -> reference -> windowphone8.1

Please help me ! thanks!
Coordinator
Sep 9, 2014 at 4:36 PM
Right Click on Project -> Retarget for Windows Phone 8.1

Does that work?

You will need to do that for all of the source projects, not just your game.

After doing this you may have to restart Visual Studio and reload the project.
Coordinator
Sep 9, 2014 at 4:46 PM
I just did this with the tests on windows phone.
  1. Right click on each project -> Retarget for Windows Phone 8.1
  2. Edit the MonoGame framework projects to include the aliases to the Microsoft XNA libraries.
  3. Rebuild all
That's it. The hardest step is #2. Both of the MonoGame projects need to be edited.

In MonoGame.Framework.Net.WindowsPhone.csproj, you need to add this at line 89, or just before the ItemGroup that has the Compile directives.

<ItemGroup>
<Reference Include="Microsoft.Xna.Framework.GamerServices">
  <Aliases>MicrosoftXnaGamerServices</Aliases>
</Reference>
<Reference Include="Microsoft.Xna.Framework">
  <Aliases>MicrosoftXnaFramework</Aliases>
</Reference>
</ItemGroup>

In MonoGame.Framework.WindowsPhone.csproj you need to add this at line 90, or wherever the ItemGroup exists that contains the Reference directives:
<Reference Include="Microsoft.Xna.Framework">
  <Aliases>MicrosoftXnaFramework</Aliases>
</Reference>

Once you do that, reload the monoGame framework projects, and go!
Sep 11, 2014 at 5:47 PM
I'is ok. Thank for your help me!
Sep 11, 2014 at 6:07 PM
I using touch layer but have a problem: When i touch in child layer then layer parrent get touch before and child is later.
I want only child layer get touch and it's parent not catch. The same two layers(up,down) ,touch in layer up then layer down not catch.




Please help!
Coordinator
Sep 11, 2014 at 6:17 PM
You need to enable the Scene Graph touch priority.

CCConfiguration.SharedConfiguration.UseGraphPriority

Set this to true and you will have z-order graph priority.